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What is search engine and why we use it?

Search engine in Drupal
What are the differences from Drupal Search API?

Why we use it?
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What is Solr?

Solr is a super fast, open source, standalone search server built on Apache Lucene.
Some of the features are:

e Advanced Full-Text Search

* Designed for High Volume traffic

* Faceted Search and Filtering

» Scalable, flexible, extensible

* Rich Document Parsing — built-in ability to index PDF’s, Word documents and more
* Multiple search indexes

* Query Suggestions, Spelling and More — advanced capability for auto-complete, spell
checking, highlighting and more

&) Weill Cornell Medicine Improving Drupal search experience with Apache Solr and Elasticsearch



Apache Solr Configuration

e Install module

* Create an index on Solr engine
* Create aview

e Attach facet filters
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Install the Drupal modules

In Drupal 8, Composer is used to manage PHP libraries. The Search APl module doesn’t

include Solarium, so dependencies need to be set via Composer with the following
commands:

S composer config repositories.drupal composer https://packages.drupal.org/8

Download the module Search API Solr Search.

S composer require drupal/search_api_solr

Install the following modules:

Facets » Faceted search interfaces that can be used on Search API se

Search API » Provides a generic framework for modules offering search ¢

Solr search » Offers an implementation of the Search API that uses an Ap:

~1 Solr Search » Enable this module for a best-practice default setup of Sear
Defaults

Optional: install Solr Search Defaults module
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Add Solr server

Go to Configuration -> Search and metadata -> Search
API.

Click “Add Server” and configure the Server.

Server name example: Local Solr Server

Search API

Home » Administration » Configuration » Search and metadata

Below is a list of indexes grouped by the server they are associated wi
comments on "Article" posts).

TYPE NAME

Weill Cornell Medicine

HTTP protocol
_http |
The HTTP protocol to use for sending queries.
Solr host *
localhost

The host name or IP of your Solr server, e.g. localhost Or www.example.com.

Solr port *
8983
The Jetty example server is at port 8983, while Tomcat uses 8080 by default.

Solr path

/solr
The path that identifies the Solr instance to use on the server.

Solr core

The name that identifies the Solr core to use on the server.

Query timeout *
5

The timeout in seconds for search queries sent to the Solr server.

MULTI-SITE COMPATIBILITY

_| Retrieve results for this site only
Automatically filter all searches to only retrieve results from this [

By default a single Solr backend based Search API server is able to in
results for this site only' below you have to ensure that you enable 'R
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Confirm Solr server is connected

At this stage, the server’s status page should show message:
"The Solr server could be reached" and "The Solr core could be accessed"

Solr server URI http://local.d8-solr.com:8983/solr/

Solr core URI http://local.d8-solr.com:8983 /solr/#/drupal

Server Connection The Solr server could be reached.

Core Connection The Solr core could be accessed (latency: 2.45909555054 ms).

If Solr Search Defaults module was installed, it can be uninstalled as it’s no longer required.
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Add search index

Go to Configuration -> Search and metadata -> Search API. Selecting the “Content” data source, options are
Click “Add Index” presented to select which bundles are to be
indexed
Index name *
B
Enter the displayed name for the index.
. ¥ CONFIGURE THE CONTENT DATASOURCE

Data sources
~I Comment

Provides Comment entities for indexing and searching. ¥ BUNDLES
~| Contact message

Provides Contact message entities for indexing and searching. Which bundles should be indexed?
: Com,em - S , O All except those selected

Provides Content entities for indexing and searching. N
- None except those selected

Custom block

Provides Custom block entities for indexing and searching. Bundles
~I Custom menu link | Article

Provides Custom menu link entities for indexing and searching. —
~ Basic page
File pag

Provides File entities for indexing and searching.
~ISearch task
Provides Search task entities for indexing and searching.

¥ LANGUAGES

_IShortcut link
Provides Shortcut link entities for indexing and searching. Which languages should be indexed?

- © All except those selected

Select one or more data sources of items that will be stored in this index. )
None except those selected

Server
° - No server - Languages
_'Solr Server "I English

Select the server this index should use. Indexes cannot be enabled without a connection to a valid, enable:

Enabled
Only enabled indexes can be used for indexing and searching. This setting will only take eff
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Add fields to index

Before search can be performed, select all the fields that should be available to search.
That is configured in the “Fields” tab.

Manage fields for search index Default Solr content index -

View Edit Fields

Processors

Home » Administration » Configuration » Search and metadata » Search APl » Default Solr content index

+ Add fields

The data type of a field determines how it can be used for searching and filtering. The boost is used to give additional weight to certain fields, fo

tags.

For information about the data types available for indexing, see the data types table at the bottom of the page.

¥ GENERAL

LABEL

MACHINE NAME

Rendered item

rendered_item

¥ CONTENT
LABEL MACHINE NAME
Title title
Authored on created
Changed changed
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PROPERTY PATH

rendered_item

PROPERTY PATH

title

created

changed

TYPE

Fulltext

TYPE

| Fulltext

| Date

| Date

BOOST oP
1.0 v| Edi
BOOST

vl [80 ~

v

M
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Add processors to the index

Last step is to add additional Manage processors for search index Default Solr content index ¢

‘processors’.

View Edit Fields Processors

Home » Administration » Configuration » Search and metadata » Search AP| » Default Solr content index

This includes items such as:
* Content access

* Ignore case (case-insensitive search) ENABLED

* Tokenizer (split into individual words) @ Contentaccess

Adds content access checks for nodes and comments.

Configure processors which will pre- and post-process data at index and search time.

~| Entity status
Exclude unpublished content, unpublished comments and inactive users from being indexed.

Highlight
Adds a highlighted excerpt to results and highlights returned fields.

HTML filter
Strips HTML tags from fulltext fields and decodes HTML entities. Use this processor when indexing HTML data - for example, node bodies for
certain text formats. The processor also allows to boost (or ignore) the contents of specific elements.

“llgnore case
Makes searches case-insensitive on selected fields.

“Ilgnore characters
Configure types of characters which should be ignored for searches.

~| Stemmer
Stems search terms (for example, talking to talk). Currently, this only acts on English language content. It uses the Porter 2 stemmer algorithm
(More information). For best results, use after tokenizing.

~| Stopwords
Allows you to define stopwords which will be ignored in searches. Caution: Only use after both ‘Ignore case' and 'Tokenizer' have run.

~| Tokenizer
Splits text into individual words for searching.

"I Transliteration
Makes searches insensitive to accents and other non-ASCII characters.

) Type-specific boosting
Adds a boost to indexed items based on their datasource and/or bundle.
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Verify search index is working

Once fields and processors are setup, going back to Default Solr content index 7
the ”"View” tab, will show the status of the index, and
at this point, the content is ready to be indexed if View Edit Fields Processors
not already set to index immediately when the index |
. Home » Administration » Configuration » Search and metadata » Search API
is created.
Default content index created by the Solr Search Defaults module
Indexing of content is done via cron and any new Index status
content will get indexed then. G

101/101 indexed

Status enabled (disable)
Datasource Content (101/101 indexed)
Tracker Default

Server Solr Server

Server index status There are 101 items indexed
Cron batch size During cron runs, 50 items w

¥ START INDEXING NOW

Index all items in batches of 50 items Index now

Queue all items for reindexing Clear all indexed data
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Create a Faceted Solr Search page

Final step is to create a search page. This is done by creating a View and create a Page.

General settings to configure:
View Settings: Show > Index (created earlier)
Page Settings:

Home » Administration » Structure » Views

VIEW RASIC INFORMATION

* PageTitle . Comments
* Path: /search/content View Log entries |
e Display Format > Unformatted list of “Rendered Entity” Z'Listem | B
Des  Content revisions
The click “Save and edit” to configure the view. Taxonomy terms
. “« H ” Users

1. Un(?er Format > Show, click “Settings” for Rendered Custom block revisions

Entity and change "view mode” to Teaser VIEW  Custom block _
2. Under Filter Criteria, add “Fulltext search” field and Show v Index Solr content index | | sorted by:

expose the field for filtering

PAGE SETTINGS

Further solr configuration can be done in the Solr schema, such as:

* Searching parts of works, using Solr’s EdgeNGramFilterFactory, for example, “info” will match
”information”
* Lower Case Tokenizer — remove whitespace and non-letters and convert all letters to lowercase

o u - =
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Add search facets

With the search page setup now, we want to add facets to let users filter down content.
Navigate to Configuration > Search and metadata > Facets then click “Add facet”

Facets 77

Home » Administration » Configuration » Search and metadata

Below is a list of facets grouped by facetsources they are associated with. A facetsource is the
instance where the facet does the actual filtering, for example a View on a Search APl index.

The facets weight can be changed with drag and drop withing the same facet source. Although
you can drag and drop a facet under any facet source, this change will not be performed on save.

TYPE

Facet
source

4  Facet
+  Facet

4  Facet

TITLE

search_api:views_page__solr_search_content__page_1

Authored on
created - datebasic

Content type
type - links

Tags
field_tags - links

® Weill Cornell Medicine

Show row weights

OPERATIONS

Configure

Edit v

Edit v

Edit -

Facets have a number of settings to configure:

- Widget

- Show the amount of results

- Sorting (by count, display value...)

- Operator (OR and AND - AND filters are
exclusive and narrow the result set. OR
filters are inclusive and widen the result
set.)

Edit Content type facet ¢

Edit Facet settings

Home » Administration » Configuration » Search and me

Widget *
Array with raw results
) List of checkboxes
") Array with raw results for date query type
) Date list
") Dropdown
O List of links
) Granular numeric list

The widget used for displaying this facet.
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Add search facets

Last step, add the newly created Facet blocks on the Block Layout page

Sidebar first Place block

4 Tags Facets Sidebar first
4 Authored on Facets Sidebar first
4 Content type Facets Sidebar first

Note: Facet blocks don’t need to have the page visibility set, it will automatically detect

if the page a search page, otherwise, they will not be displayed
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Search Page

Finally, view the search page created

Drupal 8 Solr

Home » Solr Search

Tags

 ciwupadutho (2)

Authored on

* August 2017

Content type

* Article

Weill Cornell Medicine

Search

Search

Apply

Brevitas Caecus Dolor Singularis
Submitted by admin on Fri, 09/15/2017 - 10:02

Brevitas facilisis macto minim neo utinam. Consectetuer defui duis ex importunus laoreet lucidus singularis vicis.
Cogo magna nimis obruo paulatim suscipere. Autem enismod incassum inhibeo nutus. Ideo minim pala. Enim

imputo modo nunec populus valetudo. Eu olim similis wisi.

Read more

Hendrerit Humo Ratis Sino

Eros genitus neque persto praesent quibus tum validus vicis. Commoveo metuo mos valetudo. Caecus conventio loquor ullamcorper. Damnum diam elit
enim neque nibh pneum refero tego ulciscor. Camur diam eros esse huic immitto loquor mauris nobis volutpat. Decet nutus sino. Ad dignissim oppeto
pagus.
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What is Elasticsearch?

e Also capable of providing advanced full-text search
e Easier to install
* REST based APIs, a simple HTTP interface, and uses schema-free JSON

e Distributed Document Store - easy to use JSON document-oriented storage
platform

* Logging data and analysis
e Visualization and real-time data monitoring when couple of Kibana

& Weill Cornell Medicine Improving Drupal search experience with Apache Solr and Elasticsearch
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Elasticsearch Configuration

* |nstall module

* Create an index on Elasticsearch engine

* C(Create aview
e Attach facet filters

@ Weill Cornell Medicine
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Install the Drupal modules

The Search APl module needs Elasticsearch PHP library which provides the abstract layer of Elasticsearch
Connector module in Drupal. This can be installed through composer.

S composer require nodespark/des-connector:5.x-dev
S composer update

ELASTICSEARCH

Elasticsearch Abstraction of making connection to the elasticsearch server. This r
Connector
Elasticsearch Stand alone module for integration between Drupal Views and Elasti

Connector Views

Facets » Faceted search interfaces that can be used on Search API se;

Search API » Provides a generic framework for modules offering search ¢

NOTE: Elasticsearch doesn’t have Solr Search Defaults-like module. Setting up and creating a view page has
to be done manually.
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Add Elasticsearch

Go to Configuration > Search and metadata > Elasticsearch Connector.

Click “Add Cluster” and configure the Server.

Elasticsearch Connector i~

Home » Administration » Configuration » Search and metadata

+ Add ndex

TYPE NAME MACHINE NAME STATUS CLUSTER STATUS OPERATIONS

Cluster elasticsearch (5.5.2) elasticsearch Active yellow Info v

: Weill Cornell Medicine Improving Drupal search experience with Apache Solr and Elasticsearch
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Add Elasticsearch (continue

GO tO Conﬁgu ration > Sea rCh and metadata > Home » Administration » Configuration » Search and metadata » Elasticsearch
. i “ ” Connector » elasticsearch
Elasticsearch Connector. Click “Add Cluster” and

0 CLUSTER NAME STATUS NUMBER OF NODES
configure the server.

elasticsearch yellow 1

As default, it is “elasticsearch.” If you want to edit Administrative cluster name *
the cluster/node information, edit elasticsearch.yml elasticsearch

flle. Machine name: elasticsearch
Enter the administrative cluster name that will be your Elasticsearch cluster unique
identifier.
Server URL *
http://localhost:9200
URL and port of a server (node) in the cluster. Please, always enter the port even if it

is default one. Nodes will be automatically discovered. Examples:
http://localhost:9200 or https://localhost:443.

£ Make this cluster default connection

If the cluster connection is not specified the API will use the default connection.

Use multiple nodes connection

Automatically discover all nodes and use them in the cluster connection. Then
cluster.name: elasticsearch the Elasticsearch client can distribute the query execution on random base
between nodes.

Use authentication

Use HTTP authentication method to connect to Elasticsearch.
node.name: drunode-1

Connection timeout *
3 S
After how many seconds the connection should timeout if there is no connection to

Elasticsearch.

path.data: /fusr/local/var/elasticsearch/ *
Status

@ Active

path.logs: /usr/local/var/log/elasticsearch/ Inactive
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Add search index (same as Solr)

Go to Configuration > Search and metadata > Search API.
Click “Add Index”

Edit search index Demo Index <

View Edit ‘ Fields Processors Autocomplete

Home » Administration » Configuration » Search and metadata » Search APl » Demo Index

Index name *

Demo Index Machine name: demo_index

Enter the displayed name for the index.

Data sources *
~ 1 Comment
Provides Comment entities for indexing and searching.
~ Contact message
Provides Contact message entities for indexing and searching.
Content
Provides Content entities for indexing and searching.
I Custom block
Provides Custom block entities for indexing and searching.
~ Custom menu link
Provides Custom menu link entities for indexing and searching.
File

Provides File entities for indexing and searching.
Select one or more data sources of items that will be stored in this index.

» CONFIGURE THE CONTENT DATASOURCE

Server
- No server -
© Elasticsearch Demo

Select the server this index should use. Indexes cannot be enabled without a connection to a valid, enabled server.

Weill Cornell Medicine

Selecting the “Content” data source, options are

presented to select which bundles are to be

indexed

¥ CONFIGURE THE CONTENT DATASOURCE

¥ BUNDLES

Which bundles should be indexed?
O All except those selected

“'None except those selected

Bundles
| Article
| Basic page

¥ LANGUAGES

Which languages should be indexed?
O All except those selected

"' None except those selected

Languages
_IEnglish

Improving Drupal search experience with Apache Solr and Elasticsearch
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Add fields to index (same as Solr

Before search can be performed, select all the fields that should be available to search. That is configured in
the “Fields” tab.

Manage fields for search index Demo Index s

View Edit ‘ Fields ‘ Processors Autocomplete

Home » Administration » Configuration » Search and metadata » Search APl » Demo Index

+ Add fields

The data type of a field determines how it can be used for searching and filtering. The boost is used to give additional weight to certain fields, for example titles or tags.

For information about the data types available for indexing, see the data types table at the bottom of the page.

v GENERAL
LABEL MACHINE NAME ;I:?:ERTY TYPE BOOST OPERATIONS
Rendered HTML output rendered_item rendered_item | Fulltext v| | 1.0 v| Edit Remove
v CONTENT
LABEL MACHINE NAME :ingRTY TYPE BOOST OPERATIONS
Body body body | Fulltext v| [1.0 ¥ Remove
Title title title | Fulltext v 1.0 v Remove
Comments comment comment | Fulltext v| [1.0 v Remove
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Add processors to the index (same as Solr

Last step is to add additional Manage processors for search index Demo Index s
"'processors’. e

View Edit Fields Processors Autocomplete
This includes items such as: Home » Administration » Configuration » Search and metadata » Search APl » Demo Index
¢ Conte nt access Configure processors which will pre- and post-process data at index and search time.

* Ignore case (case-insensitive search)

 Tokenizer (split into individual words) ENABLED

Content access
Adds content access checks for nodes and comments.

Entity status
Exclude unpublished content, unpublished comments and inactive users from being indexed.

 Exclude source fields

Exclude certain source fields from search results
Highlight

Adds a highlighted excerpt to results and highlights returned fields.
HTML filter

Strips HTML tags from fulltext fields and decodes HTML entities. Use this processor when indexing HTML data - for example, noc
allows to boost (or ignore) the contents of specific elements.

' Ignore case
Makes searches case-insensitive on selected fields.

Ignore characters
Configure types of characters which should be ignored for searches.
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Verify search index is working (same as Solr)

Once fields and processors are set up, go back to Demo Index v
the "View” tab. It will show the status of the
index, and at this point, the content is ready to be
indexed if not already set to index immediately

‘ View ‘ Edit Fields Processors Autocomplete

Home » Administration » Configuration » Search and metadata » Search API

when the index is created. Index status
(D
70/70 indexed 100%

Indexing of content is done via cron and any new
content will get indexed then.

Status enabled (disable)

Datasource Content (70/70 indexed)

Tracker Default

Server Elasticsearch Demo

Server index There are 70 items indexed on the server for this index. (More
status information)

Cron batch size During cron runs, 50 items will be indexed per batch.

Vv START INDEXING NOW

Index all items in batches of 50 items Index now
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Create a view page

1. Go to Structure > Add view

2. Provide a view hame and select
your index name as the view
source

Weill Cornell Medicine

Add view 7

Home » Administration » Structure » Views

VIEW BASIC INFORMATION

View name *

| Description

Cluster elasticsearch (.kibana - dashboard)
Cluster elasticsearch (.kibana - index-pattern)
VIEW § Cluster elasticsearch (.kibana - search)
Show: Cluster elasticsearch (.kibana - server) C
2 Cluster elasticsearch (.kibana - timelion-sheet)
Cluster elasticsearch (.kibana - url)
Cluster elasticsearch (.kibana - visualization)
Cluster elasticsearch (elasticsearch_index_testelastic_demo_index - demo_index)
Cluster elasticsearch (elasticsearch_index_testelastic_demo_session - demo_session)
Cluster elasticsearch (elasticsearch_index_testelastic_suggest - suggest)
Cluster elasticsearch (index - doc)
Cluster elasticsearch (metrics - datapoint)
Cluster elasticsearch (norconex - content)
_ICrea Cluster elasticsearch (norconex - user)
Cluster elasticsearch (scrapy-2017-09 - items)
Cluster elasticsearch (status - status)
Custom block

Index Demo Session

PAGE !
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Create a view page (continue)

Elastic Search (Index Demo Index)

3. Under Format > Show, select
Rendered Entity

Or, you can select “Fields” and add
each field you would like to display
in the Fields section.

4. Under Filter Criteria, add
“Fulltext search” field and expose
the field for filtering

5. Add Sort Criteria: The best one to
use is “Relevance (desc)”

® Weill Cornell Medicine

Home » Administration » Structure » Views » Elastic search » Edit

Displays

ZCEEl Search Page + Add

Display name: Search Page

TITLE
Title: Elastic Search

FORMAT

Format: Unformatted list | Settings

Show: Fields | Settings

FIELDS

Content datasource:
Content datasource:
Content datasource:
Content datasource:
Content datasource:

Content datasource:

FILTER CRITERIA

Add | v
Title (indexed field)
Authored on
Authored by (indexed field)
Image
Body (indexed field)
Tags (Tags)

Add v

Search: Fulltext search (and )

SORT CRITERIA

Add v

Search: Relevance (asc)

PAGE SETTINGS
Path: /search-demo
Menu: No menu

Access: None

HEADER Add
FOOTER Add
NO RESULTS BEHAVIOR Add -

Global: Text area (Global: Text area)
PAGER

Use pager: Mini | Mini pager, 10 items

More link: No

Improving Drupal search experience with Apache Solr and Elasticsearch
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Add search facets (same as Solr)

With the search page setup now, we want to add facets to let users filter down content. Navigate to
Configuration > Search and metadata > Facets then click “Add facet”

TYPE
Facet source

Facet source

+ Facet
+ Facet
4 Facet

TITLE

search_api:views_page__elastic_search__page_1

search_api:views_page__elastic_search__page_2

Search Page authored by
uid_1 - links

Search Page authored on
created - datebasic

Search Page Tags
field_tags - links

® Weill Cornell Medicine

Facets have a number of settings to configure:

OPERATIONS °

Configure o

Configure °

Edit A

Edit -

Edit v

Widget

Show the amount of results

Sorting (by count, display value...)
Operator (OR and AND - AND filters are
exclusive and narrow the result set. OR
filters are inclusive and widen the result
set.)

Edit Content type facet 7r

Edit Facet settings

Home » Administration » Configuration » Search and me

Widget *
) Array with raw results
) List of checkboxes
) Array with raw results for date query type
) Date list
Dropdown
© List of links
Cranular numeric list

The widget used for displaying this facet.
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Place facet blocks (same as Solr)

Last step, place the newly created Facet blocks on the Block Layout page

Sidebar first Place block

4 Tools Menus Sidebar first B Configure | ~
« Search Page Tags Facets Sidebar first E Configure =
+ Search Page authored by Facets Sidebar first E Configure v
« Search Page authored on Facets Sidebar first a Configure v

Note: Facet blocks don’t need to have the page visibility set, it will automatically detect
Each of the page a search page, otherwise, they will not be displayed.

P

Y H e . . . f
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Search Page

Finally, view the search page created.

Drupal 8 Elasticsearch

Home
Tools 3
Elastic Search
4Add content
Fulltext search
dolore
Search Page Tags
* hac(14) Apely
* bros (9)
o cribre (9)
. Importunus Nulla Os
. 5 (?.).( , 2017-10-12
SRNEDADOSERT
o wres (7) Rl
® tro (6)
* trulit (6)
* spamaki (4)
Search Page authored by
* Anonymous
* baszo19
Decet duis lenis ludus nunc olim pagus paulatim sed tincidunt. Erat esse ibidem immitto jus minim. Abigo pagus quidne.
Search Page authored on

Abluo augue commoveo defui dolor huic lobortis pecus suscipit validus. Abbas at ratis tego. Gilvus jus neque similis vero.
Cogo duis eligo esca enismod hendrerit neo si suscipit...

o April 49744 (1)
* April 49745 (1)
* August 49744 (1) Dignissim Erat Secundum

2017-10-15
bas2019
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Apache Solr or Elasticsearch?

Source: A scene from Annie Get Your Gun (1950)

o = .=
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When to use Apache Solr

If there are few thousand nodes of content (or more, depending on server
performance and whether hosted locally or externally)

* You do not want to put stress on the database
e If searching is a major feature of the site

* If you need to search multiple fields

& Weill Cornell Medicine Improving Drupal search experience with Apache Solr and Elasticsearch
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When to use Elasticsearch

* The Elastic Stack (Elasticsearch, Logstash, and Kibana) can interactively search,
discover, and analyze to gain insights that improve the analysis of time-series
data.

* No need for upfront schema definition. Schema can be defined per type for
customization of indexing process.

* Has an edge in the cloud environment - this is depend upon SolrCloud
advancement.

* Has advantages of search for enterprise or higher-ed level where analytics plays
a bigger role.
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Additional resources

Solr:
Configuring the Search API server (D8)
https://www.drupal.org/node/2763137

Drupal 8 and Solr: Google-fast search on your own website | Why and how
https://blog.openlucius.com/en/blog/drupal-8-and-solr-google-fast-search-your-own-website-why-and-
how

Set up faceted Apache Solr search on Drupal 8
https://www.jeffgeerling.com/blog/2016/set-faceted-apache-solr-search-on-drupal-8-2016-deprecated

When to consider Apache Solr
https://lastcallmedia.com/blog/when-consider-apache-solr

Elasticsearch:
Indexing content from Drupal 8 using Elasticsearch
https://www.lullabot.com/articles/indexing-content-from-drupal-8-to-elasticsearch

How to index Attachments and Files to Elasticsearch
https://gbox.io/blog/index-attachments-files-elasticsearch-mapper

Solr vs. Elasticsearch: 5 Factors to Consider
https://www.cmswire.com/information-management/solr-vs-elasticsearch-5-factors-to-consider/

£
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Questions?

@ Weill Cornell Medicine
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